Beta Program

From VuzeWiki
Jump to: navigation, search

The Beta Program gives you access to the most recent *stable* development version of Vuze. As features are developed and bugs fixed they are released to people who have joined the Beta Program once they pass initial testing.

Features may continue to evolve within the Beta releases as feedback is received and improvements/changes in approach made, however the software should run reliably and is intended for general use by people interested in sneak-peeks to upcoming features and early access to fixes.

Joining the program[edit]

To join the Beta Program go to the Help menu and select the 'Join Beta Program...' option:

Jb menu.png

Then select the 'Update me..' option and hit Finish:

Jb dialog.png

Vuze will automatically install the latest software (this may require one or two restarts depending on which components need updating).

Once this is complete you can verify that you are running the Beta software by checking the bottom left of the status bar:

You will also have a new entry in the sidebar under Vuze which gives you the details of the latest update by linking to the 'development blog' - http://devblog.vuze.com/

Jb status.png

Leaving the program[edit]

Unfortunately this is not as polished a process as joining the program. If you just want to stop receiving future updates then go to the Help menu and select 'Leave Beta Program...'. If you want to revert to non-beta software then you will need to manually uninstall and then re-install(see Clean_install).

CVS Snapshots[edit]

There will in general be incremental releases between beta releases - Beta Program members won't be updated with these as they are not deemed to be stable. If you want to run with these versions you need to either install the CVS Updater plugin (go to the Tools->Plugins->Installation Wizard and select it from there) or manually manage things. CVS snapshots can be accessed directly from http://dev.vuze.com/ if required.

The name 'CVS' comes from the original source control system used for Vuze (Concurrent Versions System) and refers to the fact that these snapshots are taken directly from the continually evolving source and can contain half-completed features etc.