Translate Vuze

From VuzeWiki
Jump to: navigation, search

Translation Process[edit]

The translation process is the same whether you want to :

  • add a new language
  • improve an existing translation

In any case, please check the internationalisation forum to be up to date on the latest translations.

Install the latest Vuze beta (optional)[edit]

To make sure you are translating the most recent version of Vuze:

Alternatively, to stay up to date all the time, you can install the Vuze Beta Updater plugin:

  • Tools⇒Plugins⇒Installation Wizard⇒By List From SF⇒Select AZCVSUpdater ⇒Next⇒Install the plugin for all users⇒Finish⇒Close.

Install the i18nAZ Plugin[edit]

i18nAZ plugin is a handy tool for modifying the language files. Install it:

  • Tools⇒Plugins⇒Installation Wizard⇒By List From SF⇒Select i18nAZ ⇒Next⇒Install the plugin for all users⇒Finish⇒Close.

Do the Translation[edit]

Open the Translation interface: Tools⇒Plugins⇒i18nAZ[edit]

  • The translation interface is a table with columns, rows and cells, similar to a worksheet.

Add a Language[edit]

Click the "Add Language" button > Select the language from the list

  • The translator can also add other languages that he knows (french, spanish, german, etc.) just to see how some strings were translated in those languages.

Select the Options[edit]

  • Check "Flat (No Tree)" and "Fancier Editor"

Translate the Strings[edit]

  • The language editor has three columns "Key", "Reference" and "Language Name (Country)"
  • The column "Key" contains the section of the resource file where the string is present (can be useful for better understanding of the context in which the string is used => in the Options, in the Toolbar, etc.)
  • The column "Reference" contains the text of the original string (in english).
  • The column "Language Name (Country)" contains the text of the translated string.
  • In order to translate a string one must select a cell under the "Language Name (Country)" column by clicking on it, then open the translation dialog by double-clicking on that cell. The dialog consists of a little window that has in its upper part a field with the reference string (in english) and in the lower part a field where the translated string must be typed. After typing the translated string and clicking OK, the translation of that particular string is done and will appear under the column "Language Name (Country)".

Saving the Translation[edit]

  • The translation is automatically saved, but clicking from time to time on the "Save" button assures that the last modifications are not lost in the case of a power failure or a system crash.
  • The translation is saved as a file with the extension .properties. It can be export anywhere on the harddisk.

Translation Tricks[edit]

  • To see only the untranslated strings, click "Filter empty" button. You can also click "Filter unchanged" and/or "Filter extra".
  • To search for some particular strings, a keyword must be typed in the "Filter" field, then the "Enter" key must be pressed. For example to display only the strings that have the word "seed" in them, that word must be typed, then Enter should be pressed. Of course, multiple keywords can be used, for example one could search the expression "seeding a torrent". To display all the strings (not only those with the keyword), one must clear the "Filter" field by deleting the keyword and then pressing "Enter", or just click on the cross in the search box.

Submit the translation[edit]

Please post your translation in the internationalisation forum

Creating a patch of the updated language module will help others understanding how extensive your changes are. You might use a file comparison tool like WinMerge to create the patch between the original language module (e.g. exctrated from azureus2.jar, or downloaded from CVS repository) and the edited module.

Note: Some times the DOS/Unix line endings can cause patch to erroneously include all lines, so watch for that. For Windows users, one way to get a Unix line-endings (like the plugin produces) is to extract the correct original messagesbundle from azureus2.jar with WinRAR or other JAR compatible archiver tool.

GeneratePatch.png


Thanks a lot!