How do you resume

From VuzeWiki
Jump to: navigation, search

You should be able to resume most downloads by following these steps.

Contents

[edit] When do you need to resume?

  • If you have started a .torrent in another BitTorrent client and want to change to Azureus, or
  • If you have lost all your .config files by updating your Azureus or CVS, or
  • If Azureus did not save your .config files because of "Socket Exception: Too many open files" error message, or
  • If Azureus insists on starting a fresh download even when some part of the files have been downloaded, or,
  • You want to continue download of an old torrent, where some of the torrent's files have already been downloaded, or,
  • You just feel like it.
  • If you lost files in a crash or deleted them by mistake and then emptied the trash, then nothing can be done. Sorry.

This page will refer to "partially downloaded files" as "partials".

Note: the same advice applies to re-adding already completed files back to Vuze. There is also a separate article Seed an existing file about that.

Note: If you want to transfer all Vuze stuff to a new computer, you should also read Copy Vuze to new computer‎.

[edit] How To

  • Pre-conditions: Azureus will resume BitTorrent partials however they started, as long as:
  1. the downloaded data ("partials") are present on your hard disk drive (HDD) and
  2. you have the original .torrent file.
  • Process:
  1. Make sure you have the exact .torrent file of what you were downloading.
  2. Make sure you know the exact location of the partials on your HDD.
  3. Open the .torrent in Azureus via (this is very important) File -> Open -> .Torrent File (No Default Save)
  4. When asked where to save the file, point it to your partials.
    If the file has already been completely downloaded, you can change the "Add mode" to "Seeding", so that Azureus knows that you think that the file should be complete.
  5. Wait. It will take a few minutes to check the data.


  • IMPORTANT NOTE: Azureus will tell you if a file with the same name already exists and will ask for your permission to check the file content's correctness. If the data in the already existing file is wrong, then it will get overwritten. So, if you try to use a different .torrent file, it is possible that you would erase the partial data you had downloaded.


Vuze42AddTorrentExistingFiles.png

  • When bringing partials from Windows NTFS partitions to a Linux partition, set the file permissions so you can read and write on the partials.
  • For BitComet partials: Before resuming a torrent started with BitComet, remove the .bc! extension from every file. This also applies to other torrent clients which append an extension to the partial files.

When correctly done:

  • The percentage completed of the torrent rises quickly while Azureus checks data integrity. Check the torrent tab or the floating progress bar if you have it open. Floating progress bars may be toggled via Tools -> Options -> Interface -> Auto Open Download Bar.)
  • You may see very high CPU and HDD activity during data-check. Disk access (starting programs, etc.) may be very slow.
  • If the tracker is offline, the download will not resume. Simply wait for the tracker to come back online.

[edit] Known issues

[edit] Windows

If the title of the torrent is different to the name of the folder that you saved your files into, you will have to ask azureus to save one folder up, stop the transfer, delete the folder azureus created, rename your download folder to the same name as the folder that azureus created (same as torrent title), and re-start the transfer and hope that azureus picks up that the files are already there. Maybe force a hash check first. According to the above, you shouldn't need to do this, but Azureus (2.1.0.0/winxp/jre1.4.2) insists on appending \<torrent title> to the end of any path its given, and it appears that there is no way to change this, short of editing the source. I have no idea if this behaviour is different in other OSes. - Triffid Hunter (triffid_hunter at funkmunch dot merseine dot nu)

Applies to

  • (Azureus 2.1.0.0 / windows XP)
  • (Azureus 2.1.0.4 / windows 2000 / j2sdk1.5.0)

[edit] Mac OS X

  1. Make sure you have a default save directory set up ("Save to default data directory" in the preferences)
  2. Put the torrent file into (path to your home directory)/Library/Application Support/Azureus/torrents
  3. Put the partial into the default save directory, or a copy of the partial if you want to keep a backup
  4. From the File menu, select "Open" -> ".torrent File"
  5. In the dialog that appears, choose the torrent file you moved into Azureus' Application Support folder
  6. Azureus should check the downloaded file and resume the download


[edit] Copies of .torrent files

You can make life easier for yourself, by making sure that Vuze keeps extra copies of the .torrent files.

During downloading and seeding Vuze has a copy of the .torrent file in the 'active' subdirectory inside your configuration directory. However, as that directory is usually at your OS user profile, it can be separated from the data and may even lie on another disk. In many cases it would be handy to have the .torrent file also near your data files.

You can easily instruct Vuze to keep extra copies of the .torrent files. Just create a new empty directory for .torrent files somewhere (near your default download directory?), and enable the option "Save .torrent files" in Files/Torrents options and point it to the correct directory. Vuze will then keep a copy of all active .torrent files also there.

Vuze4310OptionFilesTorrents.PNG


Read the Azureus FAQ